PHP 5.3 upgrade across shared/reseller hosting platform

Posted by Paul-UKWSD on October 20, 2011 in Web Hosting

This is a quick reminder that we will be upgrading the version PHP across all UK web hosting and reseller hosting servers on Friday 4th November 2011 to the latest stable release in the 5.3.x branch of PHP.

Most improvements in PHP 5.3.x have no impact on existing code. There are a few incompatibilities and new features that should be considered:


Why the long notice period?

The reason for the long notice period is to give our customers plenty of time to update their scripts (if required), PHP 5.2 has already become end of life with only security patches released on a case by case basis, there will be no more development to PHP 5.2.


What is a script?

Well when we talk about scripts we’re referring to applications such as a community forums like phpBB, content management systems such as Joomla or shopping cart systems such as OSCommerce.

Most scripts will work just fine with PHP 5.3 as it was released in back in 2009, if you’re in any doubt as to whether a script you’ve installed will work or not we recommend that you contact the script developer. Most (if not all) will have an update released that will need applying for compatibility.

Please ensure any scripts you have installed within your UK web hosting account are fully up to date to ensure there are no compatibility issues and to ensure you’re keeping your account secure.

Tags :  ,  ,  ,  ,