SSL Intermediate and Root Certificates | GlobalSign.com

You must install the appropriate GlobalSign intermediate certificate on to your server for your SSL Certificate to work transparently with all applications and browsers.

GlobalSign Intermediate Certificates

GlobalSign Root Certificates

The GlobalSign Root CA Certificate is prepopulated in all known browsers, applications and devices and is rarely needed for web server installations. If you do need it however (for example for Apache v2 installations) follow the below instructions:

GlobalSign Root Bundle Certificates

Some Apache and Java-based applications require the root and intermediate certificates to be bundled in one certificate, if you know this to be the case for your web server, download the appropriate root bundle from below:

  • 127 Users Found This Useful
Was this answer helpful?

Related Articles

Who do I contact for SSL Certificate issues?

Pre-Sales For any pre-sales enquiries relating to SSL Certificates or if you require a CSR...

I have moved servers / hosting providers. Can I use the same SSL Certificate?

Providing that the domain name does not change the same certificate be used. The certificate can...

How do I renew my certificate? Will it cost the same as before?

Our SSL Certificates are sold as a one time product with various validity periods, this means the...

What is SSL?

The SSL (secure socket layer) protocol is the Web standard for encrypting communications between...

About Intermediate Certificates

What are Intermediate Root CA certificates?All customers installing a GlobalSign SSL Certificate...